WDForge - Forum

Le forum des développeurs professionnels WinDev ®

doublon

Discussion sur WinDev®

Message non lupar malklan » Mar 30 Mai 2017 11:13

Bonjour j'ai un petit souci je n'arrive pas a controler les doublon voici mon code pourriez vous me dire le probleme
merci d'avance.
[code
]// gestion des doublon
HGèreDoublon(EXPRESS_Pronostique,Nom,Vrai)
SI SAI_Pronostiqueur = "" ALORS
Erreur("Saisie obligatoire !")
RepriseSaisie(SAI_Pronostiqueur)
FIN
// recuperation des donnéess saisies
EcranVersFichier()

// dectection des doublons

// tentative d'ajout au fichier
SI HAjoute(EXPRESS_Pronostique) = Faux ALORS

SI HErreurDoublon() = Vrai ALORS
// affichage de l'erreur
Erreur("Pronostiqueur deja enregistré")
// retour a la saisie
SAI_Pronostiqueur=""
RepriseSaisie(SAI_Pronostiqueur)
FIN
FIN
Info ("enregistrement reusi")

[/code]
malklan
Stagiaire WDF
 
Messages: 6
Enregistré le: Mar 30 Mai 2017 11:05

Message non lupar EMIDEV » Dim 4 Juin 2017 07:53

bonjour,

je ne vois pas d'erreur dans votre code
donc il fau tse pencher sur certaine choses :
- si votre base est faites par un acces OLEDB alors attention il est possible que l'acces ne detecte pas les doublon du au fait que la structure ne renvoie pas correctement les elements unique (index ou cle)

- hdoublon : test sur les elements unique de la description
donc dans votre hajoute peut etre aucune cle unique n'existe dans le fichier
je m'explique si votre fichier a une cle unique autoincrement (alors jamais l'erreur ne sera detecté puisque l'autoincrement salimente au niveau du hajoute

pour regler votre probleme il faut verifier si votre fichier a dans sa description NOM comme cle unique ou index unique sinon jamais hdoublon vous donnera le doublon
EMIDEV
Animateur WDForge
 
Messages: 14
Enregistré le: Mer 6 Jan 2016 14:23

Message non lupar malklan » Mar 6 Juin 2017 09:33

Merci pour votre réponse je regarde sa se soir et je vous tien au courant. Oui c'est bon merci d'avance
malklan
Stagiaire WDF
 
Messages: 6
Enregistré le: Mar 30 Mai 2017 11:05


Retourner vers WinDev